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Starting the 3D Viewer

When you run the 3d Viewer it should display a rotating globe displayed on the previous page. The rotation of the globe can be stopped by clicking anywhere within the display or by pressing the Escape key. 

Controlling the Model using the Mouse

All basic manipulation of the 3d model can be controlled using the mouse.

Rotating the Model

To rotate the displayed model click anywhere in the display with the left mouse button and the mouse icon should change to the rotate symbol. When it does, drag the mouse pointer in the direction you want the model to rotate. When you release the button while the mouse is being dragged, the model will continue rotating at the speed you used while dragging. 

The rotation speed can be slowed by using the - key on the keyboard. You can increase the rotation speed using the + key.

The direction of rotation can be changed using the arrow cursor keys. Pressing the right arrow key increases the speed of rotation towards the right margin of the screen, the left cursor arrow increases the speed towards the left margin. Similarly the up arrow key increases the speed of rotation towards the top of the form and the down arrow key increases the speed towards the bottom margin.

The orientation of the model can be reset to the front view by pressing the / key. When this key is pressed, the current viewing distance is retained and the model will start rotating towards the right if the model is currently rotating. Pressing the \ key resets the view to the top of the model and starts rotation towards the right if the model is currently rotating.

All model motions can be stopped by clicking once with the left mouse button anywhere on the display or by pressing the Escape key.

Zooming the Model

To zoom the displayed model click anywhere in the display with the right-hand mouse key and the mouse icon will change to the zoom icon. When it does, drag the mouse pointer down the page to zoom in on the display or drag the mouse pointer up the page to zoom out.

Panning the Model

If you hold the shift key down and then click in the display with the left mouse button, the mouse icon will change to the panning symbol. You can then drag the mouse in any direction within the display and the model will be translated in the same direction and distance that the mouse was moved from its initial location.

Loading the Sample model file

Once you have seen enough of the rotating globe, load the sample 3d binary model file pyramid.bin using the File>Read Binary Model menu item. Once the model has loaded the display should look like this:
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The Status Bar

The first three numbers in the status bar at the bottom of the window are the x,y and z coordinates of the mouse pointer in the display. The coordinates are evaluated on the plane perpendicular to the viewer passing through the centre of the 3d view. When the model is first displayed, the viewer is located directly above the centre of the model and is looking down the z axis, so the z coordinate will be the centre of the z coordinate range of the model. The x coordinate will increase as the mouse is moved to the left and the y coordinate will increase as the mouse is moved up the display. 

The fourth panel on the status bar is used for displaying surface coordinate information and is described below.

The Viewer Location Status Bar

The first three numbers in the status bar at the top of the window are the x,y and z coordinates of the current viewer location. The final three panels in the status bar display the current viewer distance, viewer azimuth and viewer inclination. The azimuth is measured clockwise from the positive y axis and the inclination is calculated so that 90 is directly above the model.

If you want to view the model from a specific location, click on any of the first three panels in the location status bar and fill in the required coordinates on the Viewer location form. 
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If you want to view the model from a specific distance or direction, click on any of the final three panels in the location status bar and enter the required distance, azimuth and inclination values.
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Note that when you use either of these methods the model will be straightened ie the rotation about the viewing direction is reset to zero. 

The Display List

At the right of the displayed model is a list of items contained in the current model. These items are organised into a tree list the structure of which can be modified using the buttons at the bottom of the form.
Each graphic item in the list has a number of attributes which can be modified:

Name: The name of any item in the list can be changed by clicking on the current name to select it and clicking once again to enable edit mode and then typing in the required changes.

Visibility: The visibility of a particular item can be controlled by toggling the check box next to the item name in the display list. The item visibility settings are saved with the binary model file, so changes to the visibility of items will be lost if the model is not saved. The visibility of a parent node controls the visibility of all child nodes in the display list, so eg all sections can be turned off by turning of the Sections item in the display list of the sample model file.

Colour: The display colour of some items can be changed in the 3D viewer by selecting the required display item from the list and clicking on the colour box displayed on the Toolbar and choosing the required display colour. Although the colour box is displayed whenever any item in the list is selected, only isosurface, facet models, simple data points and simple line items can have their colours changed.

Transparency: The transparency of some items can be changed in the 3D viewer by selecting the required display item from the list and clicking on the text box displaying the current item transparency on the Toolbar and setting the required transparency value. The transparency is a value between 0 and 1 with 0 being fully opaque and 1 being fully transparent (ie invisible).  Although the transparency text box is displayed whenever any item in the list is selected, only isosurface and facet models items respond to changes in the transparency value.

Position: The vertical position of a particular item can be controlled by selecting the required display item from the list and changing the slider or the Offset Text box to the right of the slider. All display items respond to changes in their vertical offset, and all child nodes inherit the vertical offsets of their parents.

Note that the display item attributes are saved in the binary model, so changes to any attribute will be lost if the model is not saved before exiting the viewer.

Modifying the Display List

Delete

To delete an item from the display list, select the required item in the list so that it is highlighted and then click on the Delete button below the display list. You will then be prompted to confirm deletion of the selected item. If you choose to delete the item, it will be removed from the list and the 3D model will be redisplayed.

Move

Clicking on this button allows you to move the currently selected item to a new location in the display list. When you select an item and click on this button, you are prompted to select an existing parent node to which the current data item will be added as a child. If the (optional) New Node Name is also supplied, then a child node with that name will be created under the selected Parent node and the display item selected to be moved will be added to this new node as a child (ie as a grandchild to the specified Parent node). This option has been provided so that related or particularly important (or irrelevant) display items can be grouped together and quickly turned on and off within the model. 

Up

Clicking on this button moves the currently selected display item up one location in the display list. This action is only applicable to simple display items (ie not parent nodes) and cannot be used to move an item to a new parent (ie once a child becomes the first child node of its parent, it cannot be moved any further up the list). This option has been provided to control the order in which transparent items are displayed. The display list is processed in two passes, the first displays all visible opaque items and the second displays all visible transparent items. As a result of the mechanism by which transparency is achieved, best results are obtained if the innermost transparent models are drawn first. You may need to experiment with moving display items in the list to achieve the best possible results.

Down

Clicking on this button moves the currently selected display item down one location in the display list. As for the Up button, this action is only applicable to simple display items (ie not parent nodes) and cannot be used to move an item to a new parent (ie once a child becomes the last simple child node of its parent, it cannot be moved any further down the list). 

Cyclic

If you have multiple display items belonging to a single parent which can have its display colour changed, you can use this button to apply a colour rainbow (either blue to red or red to blue) to the child nodes of the parent. When you click on this button, the number of children belonging to the currently selected node are counted and (if there are more than 2), you are prompted for the colour order and the child nodes are coloured accordingly. This option is provided for those cases where there are multiple isosurfaces included in a model. The cyclic application of colour allows the different isosurface values to be easily distinguished.

Rotate Model Buttons

The four arrow buttons at the lower right corner of the display list can be used to rotate the model by a predefined number of degrees. The left and right buttons rotate the model about the vertical display axis and the up and down arrows rotate the model about the horizontal display axis. The amount of rotation is controlled using the File > Options > Rotation Increment menu item.

The Toolbar

The toolbar provides the user with a number of methods for interacting with and controlling the 3d display in order to view and interpret the current 3d model. 

Select

The first button on the toolbar selects the default mouse behaviour mode. In this mode the mouse can be used to rotate, zoom and pan the current view as described earlier in this document. Clicking on this toolbar button turns off any other currently selected mode and returns the mouse to its default behaviour.

Scale View

The next toolbar button sets the mouse to zoom mode. This operates in the same fashion as dragging with the right mouse button except that zooming now requires dragging with the left mouse button and the mouse stays in zoom mode after the mouse button is released,

Zoom Out

The zoom out button zooms the current view out by 10%. Clicking on this button leaves all other settings and modes unaffected.

Zoom In

The zoom out button zooms the current view in by 10%. Clicking on this button leaves all other settings and modes unaffected.

Pan View

The pan view button changes the mouse to pan mode. The current view can then be panned by clicking and dragging with the left mouse button. The mouse stays in pan mode when the mouse button is released.

Rotate View

This button causes the current model to start rotation towards the right-hand margin of the form and then returns the mouse to default Select Mode. No other changes are made to the current operating mode

Get Surface Coordinate

Selecting this option from the toolbar turns on the surface coordinate picking mode and the mouse icon is changed to the crosshair icon. In this mode, moving the mouse does not change the displayed coordinate, but clicking on any element in the 3d model will result in the coordinates of that part of the component under the mouse to be identified and displayed in the status bar at the bottom of the screen. The x,y and z coordinates are calculated from the depth buffer maintained by openGL, so components close to the viewer are more accurate than those further away. The sixth panel in the status bar displays the depth value of the component returned by openGL and is of no direct interest to the user. 

If multiple components are at the location of the mouse click, the coordinates of the component closest to the viewer are returned. If there is no component under the mouse when it the button is clicked, the standard x,y and z values are displayed and the fourth panel displays “No Pick”.

If you start Surface Coordinate mode and click on the model with the right-hand mouse button the viewer will display a line from this initial location to wherever the mouse is currently located. Clicking at a new location with either the left or right mouse button will then display the distance, azimuth and inclination between the first and second points in the status bar at the bottom of the screen.

Light Position

The light position option allows the user to specify the azimuth and inclination of the lighting direction. The default directions are an inclination of 90 and an azimuth of 0. The values are specified in degrees measured clockwise from North for the azimuth and anti-clockwise positive from the azimuth direction for the inclination. This option allows the user to illuminate the 3d model from different directions to highlight features which are difficult to see using the standard lighting direction. These settings have no effect if the Light Follows Viewer option has been turned on.

The Menu System
The File Menu
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Read Binary Model

 This menu item allows the user to load a 3d binary model file into the viewer.

Save Binary Model

This menu item allows the user to save the current 3d model as a binary file. All display item attributes are saved with the binary model, but the current viewpoint and clipping planes are not.

Save VRML Model

This menu item allows the user to save the current 3d model as a VRML model file which can be viewed using one of the VRML browser add-ins (eg CosmoPlayer). All display item attributes except Name and visibility are saved into the VRML model. The current viewpoint and clipping planes are also not saved.

Read Viewpoint

 This menu item allows the user to load a particular viewpoint file which has been saved previously or created by another user. The viewpoint file contains the setting for the current viewing location, zoom factor and clipping planes. It does not contain any of the display attributes for individual display items.

Save Viewpoint

This menu item allows the user to save the current display settings so that a particular viewpoint of the 3d model can be reloaded at a later stage or sent to other users to highlight particular features in the current model. The viewpoint file saves the current viewer location, orientation and zoom factors as well any currently defined clipping planes.

Options > Two Sided Lighting

This option allows the user to change the lighting method used to illuminate the 3d model. The default value is to use two-sided lighting. In this mode there are two lights shining along the z axis, one at +infinity and one at –infinity. Turning off the two sided lighting option turns off the light at –infinity. This makes displaying the 3d model faster, but means that the model cannot be viewed from the negative z direction as it is unlit.

Options > Light Follows Viewer

This option allows the user to specify whether the light should be in a fixed location or if it should track the viewing orientation. The default is for the light to be in a fixed location, but for some 3d models it can be useful to have the lighting coming from the same direction as the viewer so that vertical parts of the model are better illuminated.

Options > Inverse Video

This option allows the user to specify whether the model background colour should be black (the default) or white. A black background is better for screen displays and a white background is better for printing. When this option is used all undefined or white item colours are switched to black if Inverse video is turned on and all undefined or white item colours are switched to black if Inverse Video is turned off.

Options > RGB Pixels

When the current display is saved as a bitmap, the display driver is assumed to specify pixels in RGB order. There are some drivers that define pixels in the reverse order, so if any saved bitmaps do not have the correct colours, try turning off the RGB pixel order option and this may solve the problem.

Options > Rotation Increment
When this item is clicked, the user is prompted to enter the desired rotation increment. This is the number of degrees by which the 3d model is rotated when the user clicks on the rotation buttons at the bottom of the display list. The value must be between 1 and 45 degrees.

The Edit Menu
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Copy

Clicking on this menu item results in the program saving the current 3D model display onto the clipboard. From there it can be Pasted into other Windows applications for use in presentations or reports.

Save Bitmap

Clicking on this menu item will bring up the Save Display to BMP dialog box. This allows the user to specify the name and location of a bmp file in which to save the current display. The bmp file created is an uncompressed 24bit bmp file and should be suitable for loading into most applications.

Mesh Definitions

Clicking on this menu item bring up the Mesh Graticule definition form:
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This form allows the user to define the distance between major grid lines to be displayed for each of the axes and the frequency of minor grid lines between the major ones. The grid lines can be used to accentuate distances in saved images and to give a better sense of the sizes of features in the 3d display

These mesh definitions are not saved in the binary model or viewpoint files.

Vertical Scale

Sometimes it can be useful to apply a vertical exaggeration to the displayed 3d model in order to highlight small scale features. When this menu item is clicked, the user is prompted at enter a vertical scale factor. The model is then redisplayed using this scale factor. The displayed coordinates are corrected for the vertical exaggeration and displayed in the status bar.

Delete Coordinate Information

There may be times when you wish to distribute copies of a 3D model with the actual coordinate locations removed. This can be achieved by clicking on this menu item, deleting the Labels display item and saving the 3D model. The resulting 3D model will have correct scale information, but will have a coordinate origin of 0,0,0 at the centre of the displayed model.

The View Menu
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The View menu item allows the user to return the 3d model to one of six predefined viewpoints: 

Top: This viewpoint is the default location used when loading a binary model and is located on the +z axis looking in the –z direction. 

Bottom: This viewpoint is located on the -z axis looking in the +z direction.

Front: This viewpoint is located on the –y axis looking in the +y direction. 

Back: This  viewpoint is located on the +y axis looking in the –y direction. 

Left: This viewpoint is on the –x axis looking in the +x direction. 

Right: This viewpoint is on the +x axis looking in the –x direction.

The Clip Planes

The Clip Planes menu item allows the user to define clipping planes to be used to restrict the amount of the model volume which is visible when displaying the model. Clicking on this menu item allows the user to select one of three clipping plane definition modes: Front/Back, Left/Right, Top/Bottom and Near/Far. Each mode gives the user control over two clipping planes an opposite axis direction. Front/Back gives the user control over the clipping planes on the –y and +y axes respectively. Left/Right gives the user control over the clipping planes on the –x and +x axes respectively. Top/bottom gives the user control over the clipping planes on the –z and +z axes respectively.
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Moving the slider control for a clipping plane to the extreme limit for that plane disables that particular clipping plane. Moving the slider away from its initial value enables the clipping plane and displays the current location of the clipping plane in the text box at the right of the toolbar. These values are displayed for information only and changing the displayed coordinates has no effect on the location of the clipping plane. 

The clipping planes are fixed relative to the coordinate axes and are not affected by the current display viewpoint or display scale.

The Near/Far clipping planes operate differently to the first three clipping plane modes. The first difference is that the Near and Far clipping plane distances are entered on an edit value form rather than through the use of sliders. The second difference is that the Near and Far planes are always perpendicular to the current viewpoint location. The final difference is that the near and far planes are used in the depth calculations for surface coordinate mode. This last difference is important as the less the distance between the near and far planes, the more accurate the depth coordinate calculation will be and vice versa.

The Reset menu

Clipping Planes

If clipping planes have been applied to the current displayed model, they can be reset to their default state using the Reset > Clipping planes menu item. All other display definitions such as viewpoint and scale factor remain unchanged. 

This menu item affects all clipping planes except the Near/Far pair. These can only be reset to their original values by manually changing them or by reloading the binary model.

Component Translations

If any the user has translated any of the components displayed in the viewer, the component translation offsets can be reset to zero by clicking on this menu item. All other display definitions such as clipping planes, viewpoint and scale factor remain unchanged.

The Help menu

About 3d Viewer

This menu item brings up the standard About Box form which displays the program version and system information.

openGL Status

This menu item brings up an information box displaying the information of the supplier and version information for the current openGL driver used to generate the 3d graphics display along with the openGL extensions supported by the driver. This information may be used to help diagnose any system problems encountered while displaying 3d models.
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