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Overview

The 3D modeller is a component of the WinDisp package for displaying and extracting information from 3d UBC inversions. It also allows combining a variety of 2d and 3d data with the inversion results to assist in the interpretation and utilisation of the inversion results. The modeller presents the inversion results as 2d sections, but the 3d model can be displayed within the 3D viewer or can be exported to VRML output for display using a VRML viewer. 

Loading a model into the 3D modeller

Start WinDisp, select the Start New Layout option, click on OK and then click on the menu item Utilities > 3D Models to bring up the 3D Modeller form:

[image: image1.png]3D Modeller
e D

iding

Meshfile [ = Load Mesh
Model file [ = Load Model

Multiplier  [1000000.0 Null Data [-7 Data Units [51x10°6 [Magnetics =]

Mesh Padding Cells

Numberonleft [ Numberatfromt [ NumberatTop [
NumberonRight | NumberatBack [ Number at Bottom [
Numberof Xcells [ NumberofYeels [ Number of Zeells [

Min easting | Min northing [ MinElevation [
Max casting [ Max northing [ Max Elevation [

Number of Xcells [ Numberof Yoels [ Number of Zoells [

Min easting | Min northing [ MinElevation [
Max casting [ Max northing [ Max Elevation [

Mesh and Model [ Daafies ] iAo ] s ] DiplOpiow | vewwom

[ Eancel | o |





The 3D Modeller interface has as its basis a region in space defined by a UBC format mesh file. This mesh file defines the limits of the region and subdivides it into rectangular prismatic cells in the X, Y and Z directions using the cell sizes. The sample file pyramid.msh contains the data:
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The first line defines the number of cells in the mesh in the X,Y and Z directions respectively. The second line defines the coordinates of the origin of the mesh at the minimum X, minimum Y and maximum Z location. The following lines contain the X mesh cell sizes (which must match the number specified on the first line), then the Y mesh cells sizes and then the Z mesh cell sizes. The cell sizes may be specified using Fortran list format with a repeat count preceding the cell size.

Note that the coordinate axes form a right-handed system with X corresponding to East/West, Y corresponding to North/South and Z to elevation (measured positive up).

Use the small command button to the right of the mesh file text box to select a mesh file and then click on the Load Mesh button to load the specified mesh. For the sample mesh file, the form will then display the mesh limits:
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There are four main parts to the Mesh and Model display. The topmost panel displays the mesh and model files along with information about the data type. The Mesh Padding Cells panel displays the number of cells at the X, Y and bottom Z extremities of the mesh which are considered to be padding cells and so are excluded when displaying the model. These padding cells are generally large cells used around the actual region of interest in an inversion to allow it to account for regional components in the data being fitted. As such, these cells are not of interest and so are not used when displaying the model. WinDisp uses four padding cells at the minimum and maximum X and Y limits of the region of interest with the padding cells being 1, 2, 4 and 8 times the cell size used in the core of the mesh. Four padding cells are also added at the bottom of the mesh with the same multipliers being used. When the mesh file is loaded, the code checks the sizes of the mesh cells at the edges and bottom of the mesh and displays the number of cells at each limit which it considers to be padding cells. 

The numbers of padding cells can be changed by clicking on the text box in the Mesh Padding Cells panel, and entering the preferred value. The padding cell counts can also be used to select a subsection of the entire model volume to highlight specific small scale features within a larger model.

The lower two panels, Total Region and Core Region, display the size and limits of the entire volume covered by the mesh and the subsection defined by the padding cell counts respectively.

Once a mesh file has been selected and loaded, the model file then needs to be specified. Click on the small button at the right of the Model File text box and select the pyramid.sus data file. This file contains the model generated by inverting a sample UBC mag inversion and contains susceptibility values for the pyramid.msh mesh file. Before a model is loaded, the user has the option of specifying the particular type of data contained in the model file and also the data value denoting a null value and a multiplier to be applied to non-null data when it is loaded. The pyramid.sus file contains susceptibility values measured in SI units and uses the value –1 to denote values in the model which are above the topography. The defaults for the 3D already agree with the data in the model file and specify that the data be multiplied by 10^6 to give more meaningful numbers for the displayed values. Some users may wish to change the multiplier to 10^5 or 10^3, depending on preference and to match susceptibility data collected from drillholes. Note that the multiplier is only applied when model files are read or written, so if the multiplier is changed, the model file will need to be reloaded for the change to take effect.

Once the model file has been selected and the data type and format specified, click on the Load Model button to load the model file into the 3D modeller. A progress bar is displayed as the model is being read and is hidden once all data has been loaded. After the model has been loaded, click on the Display Options tab to check the limits and distribution of the data in the model:
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The middle panel on this tab displays the minimum and maximum data values read from the model file and displays a histogram distribution of the data values. When the mouse is moved within the histogram display, the data value at the mouse position is displayed along with the percentage contribution for that data value.

When a data value is read from the model file, it is compared to the null data value to determine if it is null. Any value larger than the null data value is treated as being non-null. If the data is non-null it is then multiplied by the data multiplier.

Once it has been confirmed that the model file has been read correctly, click on the View Model tab to display 2D sections for the model:

The View Model tab allows the user to view a variety of 2D sections though the 3D model, change the colour stretch applied to the 2D section and to determine the location and model value for features in the section.

Interacting with the model

If the mouse is moved within the area of the form showing the section, the coordinates of the mouse location are displayed in the first two panels in the lower left corner of the form. Left and right movements of the mouse result in  changes to the first displayed coordinate, while up and down movements of the mouse result in changes to the second coordinate. Just which model coordinates these displayed coordinates correspond to depends on which section is being displayed. For a North-south section, the first coordinate is the northing (Y) and the second is the elevation (Z). For an East-West section, the first is the easting (X) and the second is the elevation (Z). For Depth Slice and Topo Drape sections, the first coordinate is the Easting (X) and the second is the Northing (Y).

If the model is clicked on with the left mouse button, the value of the model at that location is evaluated and reported in the third coordinate panel. If there is no model value at that location (either null or outside the mesh limits), then null is reported.

Section to View

This drop-down box allows the user to select which section is to be displayed. The choices are North-South, East-West, Depth Slice and Topo Drape. 

The North-South displays a vertical section through the model along a constant Easting (or X axis) value. The Easting value is displayed under the Section to View drop-down list but cannot be changed directly by the user. To change the section being viewed, move the slider control at the right-hand side of the image display until the desired easting is displayed. Note that the eastings are restricted to the centres of the cells defined in the mesh, so it may not be possible to get a specific easting value.
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The East-West is similar to the North-South section, but displays a vertical section with a constant Northing (or Y axis) value. The section displayed can be varied by moving the slider at the right.

The Depth Slice display shows a horizontal section through the model at a constant depth (or Z axis) value. 

[image: image5.png]D Modeller [_[C1x]
File Create 30 Gridding Edit Help

SectiontoView  [DephSice v Bluevalue [o 3D Viewer ﬁ

Elevation 375 Red value  [2000 Output VAML

I 595.4 | 3167 I 2808.69 | Save Grid |

WeshonaMol ] Doables ] Dildes ] s ] DinoyOpiors ] View Model

concel | 0K





The Topo Drape display is similar to the depth slice except that the model is evaluated at a constant offset from the topographic surface for the model. If no topography grid file is currently defined, the topographic surface is determined to be at the top of the first non-null cell for each vertical column of cells in the model. Depth offsets are step down using the vertical cell sizes from the topographic surface for the model.
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Blue and Red Values

These text boxes display the model data values which display as blue and red respectively. Any non-null data value less than the specified Blue value will appear as blue on the section display and any model value larger than the specified Red value will display as red. Values in between the Blue and Red values will be displayed using a colour in between blue and red. By default the colour stretch is linear between the blue and red values, but a histogram equalisation can be used by selection this option on the Display Options tab.

Section Lines and Mesh display

Also available on the Display Options tab are a number of options for displaying a border around the model, the mesh lines from the 3D mesh file and section lines displaying the current location of the other two section displays (excluding the Topo Drape section). 

The border option is provided to give a neater looking image if it is to be exported for a report. The mesh lines allow the user to determine how well resolved the features displayed in the section. The section lines are provided to give a better feeling for how features vary in a 3D sense by switching back and forth between the available display section modes and noting where a feature of interest is located within each of the sections.
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Save Grid Button

When this button is clicked, the user is prompted to select a file name and a location for saving the grid file. If a file name is supplied and the user clicks on Save, the current section grid is exported as a Geosoft binary grid file.

Output VRML

When this button is clicked, the user is prompted to select a file name and a location for saving a 3D VRML file of the current 3D model. If a file name is supplied and the user clicks on Save, the current 3D model is to a standard ASCII VRML format file which can then be displayed using one of the available VRML viewer browser add-ins (eg CosmoPlayer). The options for the 3D model will be discussed in greater detail later in this document.

3D Viewer

If the user has a 3D viewer add-in licence for WinDisp, clicking on this button will load the 3D model display scale form and then the 3D viewer form for displaying the 3D model. The use of this viewer is described in detail later in this document and also in the Using the 3d Viewer document.

Point Data Files

Point data files can be displayed in the section display and 3D viewer by defining the data files and loading the data on the Data Files tab:
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This portion of the 3D modeller allows the user to select one or two data files for display eg magnetic surface data could be the first file and CDI data for the second. The selection and file format and display options for the two data files are identical. The only difference is that the first file is displayed using small dark blue points and the second is displayed using larger light blue points.

To illustrate the use of point data select the mag.obs file (which contains the data used for the inversion) as the observed data file, specify 4 as the Value column, turn on the Colour using Value check box and click on the Load Locations command button. You may also wish to click on the View File button to see what the data file looks like. Once the data file has been loaded, click on the View Model tab and you should see the coloured data points displayed in the various sections. When an East-West or North-South section is displayed, only those points directly above the displayed section of cells are displayed in the section view. For Depth Slice or Topo Drape, all data points loaded from the data file are displayed in plan view (regardless of the z coordinate read from the file.

Observed Data Check Box

The display of the loaded points can be toggled on or off using this check box. This can be useful if there are a large number of data points and this is slowing doen the display of the section grids.

First Data Line

The value in this text box specifies which line in the data file is the first one to contain valid data to be read. This value must be 1 or larger.

X,Y Columns

The value in these text boxes specify which columns in each line in the data file contain the x and y coordinate values. These values must both be 1 or larger.

Read Increment

The value in this text box specifies the data line read increment. A value of 1 indicates that all lines will be read from the data file. A value of 2 specifies that only every second data line will be read and so on. This value must be 1 or larger.

Z Column

The value in this text box specifies which column in each line in the data file contains the z coordinate value. If this value is left blank or set to –1, then the z coordinate for each location is defined as one half of the cell height above the top of the first non-null cell directly beneath the location defined by the x and y coordinates.

Value Column

The value in this text box specifies which column in each line in the data file contains an optional value field. No data value will be read if this value is left blank or set to –1. The value field can be used to colour the displayed data point or can be used for creating a model using 3D gridding.

Colour Using Value Check Box

If the display of the loaded points is turned on and a value field has been defined, then turning on this check box will result in the data values being coloured according to the value field.

Colour Min and Max

The values in these text boxes specify the values for the Value column in the data file which display as blue and red respectively. Data between these values have a linear colour stretch between blue and red applied. Data below the minimum will be displayed as blue and those above the maximum will be displayed as red.

Define Coordinate Transform Button

 Clicking on this button brings up the Coordinate Transform definition form:
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This form allows the user to define a transformation of the coordinate values in the data file to match the actual coordinates used in the mesh and model eg converting from a local mine grid to UTM coordinates. The transformation can be specified using either a single point by defining scale, rotation, translation and elevation shift factors. The transformation can also be defined using the original and transformed coordinates of two points together with an elevation shift. The coordinate transformation can also be saved to a data file for later use, or an existing transformation can be loaded onto this form.

Drill Holes

Creating 3D models from multiple section grids

Start WinDisp, click on OK and then click on the Edit>3d Models menu item to bring up the 3D Modeller form. Click on the 3D Files tab at the bottom of the form and then click on the Section Grids tab on the top of the form.

Click on the number 1 in the grid in the centre of the form, then click on the small button at the right of the Section Grid File text box and select the grid file you want. After it is selected, the limits of the grid are filled in on the form, but you can change these as required. The Start Grid
and End Grid fields are the left and right clipping limits applied to the x direction coordinate defined in the grid file and the Top and Bottom grid limits are the clipping limits applied to the y axis coordinate in the grid file. The Elevation at Top is the actual elevation of the Top Grid
clipping value and will generally be the same as the Top Grid value, but can be modified if the actual RL is different from that supplied in the grid. The really important fields are the Line Azimuth and the Start easting and Start northing fields as these define how the section grid coordinates are converted to real display coordinates. The Start easting and Start northing are the real world coordinates of the Start Grid location in the grid file and the azimuth field is the azimuth of the line from this location measured in degrees and postive clockwise from due North.


You can also supply a description of the contents of the grid (for later reference) and you can toggle the display of individual grids, so that you can grid selected groups of lines without deleting the grids from the display list and then adding them back in later.

Once the first grid has been defined, click on the Save Changes button and the description of the grid (the grid file name by default) will appear in the display list. To define the second grid, click on the number 2 at the left of the list and enter the required information to specify the location of the section and repeat this process for as many grids as required.


To modify any information for a grid already entered, scroll through the list until the required grid is in view, click on the number in the first column. The information for the grid will then be displayed in the lower part of the form. Change any of the values as needed and click on the Save Changes button to store the new grid details.


Once all your grids have been defined, turn on the Display Section Grids check box at the top of the form and then click on the Create> Mesh From> Section Grids menu item at the top of the form. This will bring up the mesh generation form. The basis of the 3d modeller is a defined volume in 3d space which is subdivided into a mesh of rectangular prisms using a uniform mesh in each of the three axis directions. So when you click on this menu item, the program works out the volume encompassing the section grids specified and selects cell sizes from the grid cell sizes. The cell sizes are what will be used to generate the 3d model from the section grids, so you need to ensure that they are small enough to resolve the structures of interest, but not so small that you have too many cells or that there are too many cells between the section grids (basically the same issues as in 2d gridding).


Once the volume limits and cell sizes are satisfactory, click on the Done button and you will be prompted to enter the name of a file in which to save the mesh. Once you have specified a name, the mesh file is written and you are returned to the Mesh and Model tab on the 3d modeller form. This will now display the newly defined mesh.


With the mesh loaded, the volume you will be working with is fully defined, but you do not yet have any model defined for the mesh. To define the model click on the Display Options tab and specify the data multiplier and null data value appropriate for the data you are working with. For example a multiplier of 1 and a null value of –1 would be appropriate for chargeability data and a multiplier of 1000000 and a null value of –1 would be appropriate for susceptibility data. Once the data multiplier and null data values have been defined, click on the Create > Model from Mesh menu item and a model will be created and you will be prompted to supply the name of a file in which the model should be saved. Once a file name and location is specified, the model is written to the file and then loaded to make it current. If you click on the View Model tab you should see a simple blue section image.

Once these steps have been performed, you now have a fully defined 3d volume, model and section grid layout and you should save the layout using the File > Save Model Layout menu item and you can view the current model by clicking on the View Model tab. This will be a pretty boring blue display as the created model is defined to be 1.e-6 for all cells. 


Return to the 3d Files > Section Grids tab and you are now ready to generate the 3d model from the section grids. Fisrt you need to specify the search radius for gridding the data. This is a horizontal distance and thus needs to be specified as a value larger than the maximum line separation between the sections. If the section grids are clipped to the topography for the area of interest, you should use a search radius of zero as otherwise the gridding process will not generate data at the higher topo levels. Once the search radius has been set click on the Generate 3D Model button to grid the data. The program then grids the section grids by loading the data from the section grids onto the mesh for each depth slice in the 3d model and using minimum curvature to grid the data points. This is a pretty unsubtle technique, but it works reasonably well with shallowly dipping and steeply dipping structures. Once the gridding is complete, return to the View Model tab and check that the results are reasonable. If they're not ok, you may need to play around with the mesh definitions or the search radius to improve them. If the model is ok, you need to save it again.

If you have a topo grid file for the region you're working with, you can specify the topo grid on the Topography Image Files tab on the 3D Files tab. You can then mask the 3d model using this topo file from the Edit > Mask Model using Topo Grid menu item (don't forget to save the model again).

Once all this process is complete, you now have your full 3d volume and model and you can view and save sections and depth slices in the View Model tab. To generate 3d model displays, set the Red Susceptibility value to the cutoff value of interest (multiplied by the data multiplier of course). 

If you have a 3d Display licence, click on the View 3d Model button on the View Model tab and the World Model definition form will be displayed. The only important thing to define on this form is the world model scale. This acts much the same as a map scale except that it applies in 3D, so it is the scale factor that converts user distance units to world cm units. As the size of all text is defined in cm on the 3D modeller tab, the best scale is one which makes the text size visible relative to the 3D model, but not too large or small. I’ve found that aiming for x and y extents (displayed on the form) of about 30 to 100 gives a good balance, with 30 making the text large and 100 making the text small.

Once the 3D model is displayed, you can make changes on the 3D modeller form and display the changes in the current 3D viewer by clicking on the Reload menu item and selecting the item which need to be loaded again.

Once you have set up a 3D model you can save it to a binary file for distribution by using the File> Save Binary Model menu item. You can also save a particular point of view using the menu item File> Save Viewpoint.

If you do not have a 3d Display licence, the View 3d Model button won't let you view the model directly, but you can save the to a 3d file using the Output to VRML button. VRML is a Virtual Reality Modelling Language file and there are a number of add-ins you can load into your web browser that will allow you to view the model in 3d. I've included CosmoPlayer on the CD which works pretty well in Internet Explorer for viewing these files.


Notes for generating 3d vector displays

1. Start WinDisp and use the menu item Edit>3dModeller to load the 3d modelling form

2. Click on the Drill Holes tab and then click on the Define/Load Data Files button to bring up the drillhole definition form

3. Click on the small button to the right of the Data file text box on the Assay File tab and select the drillhole data file

4. Change the First data line field to 2 as your data file has a header line

5. Click on the Miscellaneous tab and turn on the Invert Z coordinate check box

6. Click on the Assay Fields tab. Click on the first Data Column cell in the assay field grid and enter the column number of the x vector component (ie 5) and then click on the Name cell and replace the value

5 with dx. Repeat this for the second row specifying dy (ie 6 and dy) and the third row to specify dz (ie 7 and dz). Note that you don't have to specify the components in any particular order or use the names dx, dy and dz, but you do need to have at least three columns to use for the components in order to display the 3d vectors.

7. Click on the Load Drill Holes command button to read the assay file and the selected data columns.

8. Click on the Miscellaneous tab again and click on the Display Drillhole Stats button to check that the data has been read correctly and that the vector components look ok.

9 Click on the Done button to dismiss the stats form and Done again to dismiss the drillhole form

10. Turn on the Display Drill Holes check box, so that drillholes will be displayed and set the Label Size to 1. 

11. Click on the menu item Create > Mesh From > Drillhole Data to bring up the Mesh definition form

12. Change the x and y mesh cell sizes to 10 and change the x limits to 260600,260900 and the y limits to 6944600,6944800 (This gives a bit of padding around the drillholes and a reasonably small mesh and model file. You only need a finer mesh if you are going to generate a 3d grid from assays from multiple drillholes). Then click on Done and save the mesh to a file.

13. Click on the Create > Model From Mesh menu item and specify a file name to save the model.

14. Click on the 3d Viewer button and change the World plot scale to 1000 and click on Done to bring up the 3d viewer and you should see the drillhole traces within the 3d model frame.

15. Leave the 3d viewer running and go back to the 3d modeller, click on the Drill Holes tab and change the Style to 3d vector. Select dx from the drop-down list for the X component, dy for Y and dz for Z.

16. Go back to the 3d viewer and click on the Reload > Drillholes menu item and you should see the 3d vectors displayed on the drillhole traces. (You may need to change the length scale field on the 3d modeller form to see the 3d vectors better - I used a value of 5 for this data).

17. You may need to play around with the mesh limits/ label sizes/plot scale and length scales to get the best display depending on just what aspect of the data you want to emphasise.

18. Once you are happy with the display, click on the File > Save Binary Model menu item to save the 3d file which can then be loaded into the viewer.

Defining Profiles in multi-panel displays

1. Start up windisp and go to the Profile tab on the Multi-panel display form 

2. Select the profile data file 

3. Click on the Define File Format button and specify the format 

4. If the file is a standard (AMIRA) tem file, everything is as it was before. If it's not, windisp will display some more command buttons to allow you to define the relevant columns and format 

5. Click on the Define Data Names button (if required) and specify the names of the data columns 

6. Click on the Define Macro Names button and define any derived quantities 

7. Click on the Define Profile Coordinates button and select the (option) line number and (mandatory) along line coordinate columns 

8. Click on the Define Channel Display button and turn off any columns (such as line number, x coord etc) fields which do not need to be displayed 

9. Click on the Read Profile file button to read the data file and specify the min/max x/y data limits 

10. Modify the Plot Style/axis height/Cm per decade fields so that the profiles will display at the scale you desire (If you change the Plot Style it's a good idea to read the file again and reset the axis height) 

11. Click on Done, ensure the panel is turned on, click on Done again, set the plot scale and display the profiles

Depth of Investigation utility for IP inversions

To use the utility, start windisp and click on OK to start a new layout. Then click on the menu item Edit> Import UBC IP inversion to bring up the Import form. On the inversion Files tab select all the res and ip files used for the base inversion by double-clickin on the file name text box or on the button at the right. (I'll try to add an automatic file selection process that selects all the file once you choose a res/voltage file, but that can wait a little while). If there are no DOI inversion files you can then click on the Generate grids and layouts button to set up the standard grid files and layouts for the inversion. If you do have DOI files click on the second tab and select the relevant files before clickong on the Generate button.

When you click on the Generate button, you'll be prompted to specify the name of a data file to store the IP data. The process generates quite a few grid and conour files, so it's probably best to create a new sub-directory
and store the IP data file in it. The process uses the file name you specify to create a sub-directory below where the IP data file is to be created (with the same name as the data file, but with _ubc appended).

The program then creates the IP data file and generates grids and contours for the observed IP data and a csf file for displaying the observed pseudosections and topo (if there is any). Once this has been created, the inversion and error csf files are also created. The csf with err in it displays observed and modelled pseudosections for res and ip as well as %difference and Z-score pseudosections so you can see how good the fit is.

After generating the base layout, the program then reads the mesh, topo and model files, masks the res and ip using the doi inversion, writes out an xyz data file and generates the grids and contours required for the error and inversion layouts. Once the process is complete, click on Done to get rid of the import form and select the layout you want to display from the file list under the File menu item. You may have to play around with the bottom depth for the inverted models as my default bottom depth is fairly conservative.


To use the DOI with DCIP2D:

- perform a first inversion with some reference model (mref1).

- perform a second inversion with a different reference model (mref2).

  mref2 should be different from mref1 by about a factor of 5.

  Also, when you are doing the second inversion, the only parameter

  in the interface that you should change is the "reference model".

- When the inversions are finished, make sure that in both cases they

  have converged, and are equal to the reference model at depth.

- the DOI index is calculated using the following formula:

  DOI = (m1 - m2) / (mref1 - mref2)

  where m1 and m2 are the inversion results.

  Therefore, on the surface where the model is controlled by the data,

  DOI is close to 0.  However, at depth where the inverted model approaches

  the reference model, the DOI approaches 1.

